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The Week's Agenda

Mon Introductions: Cloud Computing, Nuvem 

Cloud, Basic Analysis in Galaxy

Tues Nuvem or AWS?, Workflows, Sharing, Quality 

Control, ChIP-Seq

Wed Genome Assembly, RNA-Seq

Thur RNA-Seq continued, SNP and Variant Calling

Fri Intro to Command Line, Genome Annotation 

using MAKER, CloudMan and AWS

bit.ly/gxyusp2014



Tuesday's Agenda

9:00 Nuvem or AWS?

9:40 Introduction to Using Galaxy, continued 

    Exercise, Workflows and sharing

  20 minute Break at around 10:20

10:50 Next Generation Sequencing (NGS) Data 

Quality Control
12:00 Lunch

2:00 Open Discussion and Q & A

2:15 NGS QC, continuted

3:00 ChIP-Seq Analysis

  20 minute Break at around 3:20

5:00 Done
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Exons & Repeats: Exercise

Include exons with no overlaps in final output. 

Set the score for these to 0. 

!

Everything you need will be in the toolboxes we used 

in the Exon-Repeats exercise yesterday. 

!

First, what exactly did we do yesterday?
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What we did yesterday: counting
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Join on exon name

0	



0	



0

1	



1	



2

Rearrange columns w/ 

cut

What we did yesterday: formatting





Note: In your solution, you can take advantage of the fact that 

Exons already have 0 scores.



One Possible Solution

Solution from Stanford Kwenda and Caron Griffiths in Pretoria. 

Takes advantage of the fact that Exons already have 0 scores.



Basic Analysis: Further reading & Resources

http://usegalaxy.org/galaxy101 

  https://vimeo.com/76343659 

https://vimeo.com/76343659


Dataset: 
Any input, output or intermediate set of data + metadata 

History: 
A series of inputs, analysis steps, intermediate datasets, 

and outputs 
Workflow: 

A series of analysis steps 
Can be repeated with different data

Some Galaxy Terminology



Exons and Repeats History → Reusable Workflow?

• The analysis we just finished was about 

• Human chr22 

• Overlap between exons and Repeats 

• But, ... 

• there is nothing inherent in the analysis about 
humans, exons or repeats 

• It is a series of steps that sets the score of one 
set of features to the number of overlaps from 
another set of features.



Extract Workflow from history 

Create a workflow from this history. 
Edit it to make some things clearer. 
!

          (cog) → Extract Workflow 

!

Run / test it 
Guided: rerun with same inputs 
     Did that work? 
!

On your own: 
     Count # of exons in each Repeat 
     Did that work?  Why not? 
      Edit workflow: doc assumptions

Create a Workflow from a History



Share: 
Make something available to someone else 

Publish: 
Make something available to everyone 

Galaxy Page: 
Analysis documentation within Galaxy; easy 

to embed any Galaxy object 
!

Let’s all share...

More Galaxy Terminology



Reproducibility:  Everybody talks about it, but ... 
!

Galaxy aims to push the goal of reproducibility from the 

bench to the bioinformatics realm 
!

All analysis in Galaxy is recorded without any extra effort 

from the user. 
!

Histories, workflows, visualizations and pages can be 

shared with others or published to the world. 

Sharing & Publishing enables Reproducibility



Sharing & Publishing enables Reproducibility



Sharing & Publishing enables Reproducibility



!

   http://usegalaxy.org/u/aun1/p/windshield-splatter

Sharing & Publishing enables Reproducibility

http://usegalaxy.org/u/aun1/p/windshield-splatter


Data Libraries 
Make data easy to find  

!

Genome Builds 
Care about a particular subset of life? 
!

Galaxy Tool Shed 
Wrapping tools and datatypes

Sharing for Galaxy Administrators Too



Tuesday's Agenda

9:00 Nuvem or AWS?

9:40 Introduction to Using Galaxy, continued 

    Exercise, Workflows and sharing

  20 minute Break at around 10:20

10:50 Next Generation Sequencing (NGS) Data 
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12:00 Lunch

2:00 Open Discussion and Q & A
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5:00 Done



ChIP-Seq: FASTQ data and quality control 

http://scriptogr.am/ohofmann 

By Shannan Ho Sui 

!

Look at two transcription factor  

proteins, Pou5f1 and Nanog,  

in H1hesc cell lines. 

!

Both are involved in self-renewal of  

undifferentiated embryonic stem cells.

H3ABioNet 



ChIP-Seq Analysis: Get the Data 

!

Import 

Shared Data → Data Libraries → 

ChIP-Seq Datasets  → Unfiltered Reads 

H1hesc_Input_Rep1_chr12_unfiltered.fastq 

!



NGS Data Quality Control

• FASTQ format 

• Examine quality in an Chip-Seq dataset 

• Trim/filter as we see fit, hopefully without 

breaking anything. 

!

Quality Control is not sexy. 

It is vital.



What is FASTQ?

• Specifies sequence (FASTA) and quality scores (PHRED) 

• Text format, 4 lines per entry 

!

!

• FASTQ is such a cool standard, there are 3 (or 5) of them!

http://en.wikipedia.org/wiki/FASTQ_format

!
SSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSS!

    ...............................IIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII!
    ..........................XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX!
    !"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`abcdefghijklmnopqrstuvwxyz{|}~!
    |                         |    |        |                              |                     |!
   33                        59   64       73                            104                   126!
!
   S - Sanger       Phred+33,  93 values  (0, 93) (0 to 60 expected in raw reads)!
   I - Illumina 1.3 Phred+64,  62 values  (0, 62) (0 to 40 expected in raw reads)!
   X - Solexa       Solexa+64, 67 values (-5, 62) (-5 to 40 expected in raw reads)!

   @SEQ_ID!
   GATTTGGGGTTCAAAGCAGTATCGATCAAATAGTAAATCCATTTGTTCAACTCACAGTTT!
   +!
   !''*((((***+))%%%++)(%%%%).1***-+*''))**55CCF>>>>>>CCCCCCC65!

http://usegalaxy.org/community


NGS Data Quality: Assessment tools

NGS QC and Manipulation → FastQC 

Gives you a lot of information but little control over 

how it is calculated or presented.

http://bit.ly/FastQCBoxPlot

http://bit.ly/FastQCBoxPlot


NGS Data Quality: Sequence bias at front of reads?

From a 

sequence 

specific bias 

that is 

caused by 

use of 

random 

hexamers in 

library 

preparation. 

Hansen, et al., “Biases in Illumina transcriptome sequencing caused by 

random hexamer priming” Nucleic Acids Research, Volume 38, Issue 12 (2010)

http://nar.oxfordjournals.org/cgi/content/abstract/38/12/e131


• Trim as we see fit: Option 1 

• NGS QC and Manipulation → 

FASTQ Trimmer by column 

• Trim same number of columns 

from every record 

• Can specify different trim for 5’ 

and 3’ ends

NGS Data Quality: Trim as we see fit



NGS Data Quality: Base Quality Trimming

• Trim Filter as we see fit: Option 2 

• NGS QC and Manipulation → 

Filter FASTQ reads by quality 

score and length 

• Keep or discard whole reads 

• Can have different thresholds for 

different regions of the reads. 

• Keeps original read length.



NGS Data Quality: Base Quality Trimming

• Trim as we see fit: Option 3 

• NGS QC and Manipulation → 

FASTQ Quality Trimmer by 

sliding window 

• Trim from both ends, using 

sliding windows, until you hit a 

high-quality section. 

• Produces variable length reads



Options are 

not mutually 

exclusive

Option 1 

(by column) 

!

+ 

!

Option 2  

(by entire row)



Trim? As we see fit?

• Introduced 3 options 

• One preserves original read length, two don’t 

• One preserves number of reads, two don’t 

• Two keep/make every read the same length, one does 

not  



• Choice depends on downstream tools  

• Find out assumptions & requirements for downstream 

tools and make appropriate choice(s) now. 

• How to do that? 

• Read the tool documentation 

• http://biostars.org/ 

• http://seqanswers.com/ 

• http://galaxyproject.org/search

Trim? As we see fit?

http://biostars.org
http://seqanswers.com
http://galaxyproject.org/search


Does MACS care?  Maybe

• Trim Filter as we see fit: Option 2 

• NGS QC and Manipulation → 

Filter FASTQ reads by quality 

score and length 

• Keep or discard whole reads 

• Can have different thresholds for 

different regions of the reads. 

• Keeps original read length.



NGS Data Quality: Further reading & Resources

FastQC Documenation 
!

Read Quality Assessment & Improvement  
by Joe Fass 

From the UC Davis 2013 Bioinformatics Short Course 

!

Manipulation of FASTQ data with Galaxy 
by Blankenberg, et al.

http://www.bioinformatics.babraham.ac.uk/projects/fastqc/Help/3%2520Analysis%2520Modules/
http://training.bioinformatics.ucdavis.edu/docs/2013/09/short-course-2013/MonAM-readQAI-lecture.html
http://training.bioinformatics.ucdavis.edu/docs/2013/09/short-course-2013/index.html
http://bioinformatics.oxfordjournals.org/cgi/pmidlookup?view=long&pmid=20562416
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ChIP-Seq Analysis: Get the Data 

!

Shared Data → Data Libraries → 

ChIP-Seq Datasets 

Select everything in the Filtered Reads folder 

!

Also grab genes_chr12.gtf from  

library



!

Use Bowtie2 (could also use BWA) 

NGS Mapping: → Bowtie2 

FASTQ file → H1hesc_Nanog_Rep1 post-QC 

Single End 

ChIP-Seq Exercise: Mapping with Bowtie



!

Convert BAM to SAM 

SAM Tools → BAM-to-SAM 

ChIP-Seq Exercise: Mapping with Bowtie



!

SAM Tools → Filter SAM 

• Click Add a new Flag 

• Set Type to The read is unmapped  

• Set flag state to No. 

!

ChIP-Seq Analysis: remove unmapped reads



!

SAM Tools → SAM-to-BAM 

!

Get the the control (already mapped for us) 

Shared Data → Data Libraries → Aligned → Import 

H1hesc_Input_Rep1 Mapped into current history

ChIP-Seq Analysis: Put mapped reads in BAM



NGS: Peak Calling → MACS 

Experiment name → MACS NanogRep1 

Tag File → Nanog Rep1 BAM file 

Control File → H1hesc_Input_Rep1 Mapped BAM file 

Tag Size → 36 

Leave MFOLD → 32 

Save shifted raw tag count ... → Save (leave resolution at 10) 

Check Perform the new peak detection method (futuredir)

ChIP-Seq Analysis: Find Peaks



!

Look at the HTML report dataset 

!

Launch a Trackster visualization and bring in  

the called peaks 

the Treatment WIG 

the Control WIG  

the gene definitions 

ChIP-Seq Analysis: Visualize Results



!

Shared Data → Data Libraries → ChIP-Seq Datasets → 

MACS Outputs 

Import Peaks files for  

Nanog Rep 2 

Pou5f1 Rep 1  

Pou5f1 Rep 2  

ChIP-Seq Analysis: Replicates



!

Operate on Genomic Intervals → Concatenate 

Concatenate Nanog Rep 1 and 2 peak files 

!

Operate on Genomic Intervals → Cluster  

Use default parameters 

Rename the output dataset 

!

Add the Nanog cluster output to your visualization

ChIP-Seq Analysis: Unify Replicates



Repeat for Pou5f1 replicates 

Operate on Genomic Intervals → Concatenate 

Concatenate Pou5f1 Rep 1 and 2 Peak files 

!

Operate on Genomic Intervals → Cluster  

Use default parameters 

Rename the output dataset 

!

Add the Pou5f1 cluster output to your visualization

ChIP-Seq Analysis: Unify Replicates



Operate on Genomic Intervals → Subtract 

First dataset clustered → Pou5f1 

Second dataset clustered → Nanog 

Return → Intervals with no overlap

ChIP-Seq Analysis: Differential binding



ChIP-Seq Mapping With MACS 
 Further reading & Resources

ChIP-Seq: FASTQ data and quality control 

by Shannan Ho Sui 
!

 HAIB TFBS ENCODE collection 
!

MACS Documentation 
!

Model-based analysis of ChIP-Seq (MACS) 
by Zhang et al. 

!

Cistrome and Nebula Galaxy Servers 
!

Nebula Tutorial 
by Valentina Boeva

http://scriptogr.am/ohofmann/post/chip-seq-fastq-data-and-quality-control
http://hgdownload.cse.ucsc.edu/goldenpath/hg19/encodeDCC/wgEncodeHaibTfbs/
http://liulab.dfci.harvard.edu/MACS/00README.html.%0A%0Ahttp://liulab.dfci.harvard.edu/MACS/00README.html.%0A%0A
http://www.ncbi.nlm.nih.gov/pubmed/18798982
http://cistrome.org
http://nebula.curie.fr/
http://nebula.curie.fr/static/nebula_tutorial.pdf


Thanks

Dave Clements 

!
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