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Agenda: Day 1
9:30 Welcome

10:00 Basic Analysis with Galaxy 
A worked example demonstrating Galaxy Basics 

10:50 Break

11:10 Basic Analysis (continued)

12:30 Lunch (on your own)

13:30 RNA-Seq Analysis 
Quality Control and Galaxy Workflows

15:00 Break

15:20 RNA-Seq Analysis 
Mapping and Splice Junction Identification

17:00 Done
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Goals

Provide a basic introduction to using Galaxy for 

bioinformatic analysis. 

Demonstrate how Galaxy can help you explore and 

learn options, perform analysis, and then share, 

repeat, and reproduce your analyses.



This workshop will not cover  

• details of how tools are implemented, or 

• new algorithm designs, or 

• which assembler or mapper or peak caller or ... is 

best for you. 

This workshop does cover ChIP-Seq and RNA-Seq but 

you won't be an expert at either of these at the end of 

the workshop. 

You will know enough to get started, and how to use 

Galaxy to learn more.

Not Goals



What is Galaxy?

Data integration and analysis platform that 

emphasizes accessibility, reproducibility, and 

transparency  

http://galaxyproject.org

http://gmod.org/wiki/Computing_Requirements


Galaxy is available online, for free

http://usegalaxy.org  

As a free (for everyone) web server integrating a 

wealth of tools, compute resources, petabytes of 

reference data and permanent storage 

However, a centralized solution cannot support 

the different analysis needs of the entire world.

http://usegalaxy.org


Galaxy is available as Open Source Software

Galaxy is installed in locations around the world. 

Some of them are free for anyone to use too. 

http://getgalaxy.org 

bit.ly/gxyServers

http://usegalaxy.org
http://bit.ly/gxyServers


http://aws.amazon.com/education 

http://globus.org/ 

http://wiki.galaxyproject.org/Cloud 

Galaxy is available on the Cloud

http://usegalaxy.org/cloud
http://wiki.galaxyproject.org/Cloud


Galaxy is available with Commercial Support

A ready-to-use appliance 

(BioTeam) 

Cloud-based solutions 

(ABgenomica, AIS, 

GenomeCloud) 

Consulting & Customization 

(BioTeam, Deena 

Bioinformatics) 

Training  

(OpenHelix)



Galaxy Project: Further reading & Resources

http://galaxyproject.org 

http://usegalaxy.org 

http://getgalaxy.org 

http://wiki.galaxyproject.org/Cloud 

http://bit.ly/gxychoices

http://wiki.galaxyproject.org/Cloud
http://bit.ly/gxychoices
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Basic Analysis

Which exons have most overlapping 

Repeats? 

Use Human, HG38, Chromosome 22 

test.galaxyproject.org 

(~ http://usegalaxy.org/galaxy101 )

http://test.galaxyproject.org
http://usegalaxy.org/galaxy101


Exons & Repeats: A General Plan

• Get some data 

• Get Data → UCSC Table Browser 

• Identify which exons have Repeats 

• Count Repeats per exon 

• Visualize, save, download, ... exons with 

most Repeats

(~ http://usegalaxy.org/galaxy101 )

http://usegalaxy.org/galaxy101


(Identify which exons have Repeats) 

Exons Repeats



Operate on Genomic Intervals → Join 

(Identify which exons have Repeats)

Exons Repeats

Exons

Repeats

Overlap pairings



Exons Repeats

1

1

2

Exons

Repeats

Overlap pairings

Exon overlap counts

Join, Subtract, and Group → Group  

(Count Repeats per exon)



Exons

1

1

2

Exon overlap counts

We’ve answered our question, but we can do better. 

Incorporate the overlap count with rest of Exon information 



Exons

1

1

2

Exon overlap counts

1

1

2
Join on exon name

0

0

0

Join, Subtract, and Group →Join 

(Incorporate the overlap count with rest of Exon information) 



Exons

1

1

2

Exon overlap counts

1

1

2
Join on exon name

0

0

0

1

1

2

Rearrange columns w/ 

cut

Text Manipulation →Cut 

(Incorporate the overlap count with rest of Exon information) 
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Exons & Repeats: Exercise

Include exons with no overlaps in final output. 

Set the score for these to 0. 

Everything you need will be in the toolboxes we used 

in the Exon-Repeats exercise. 



One Possible Solution

Solution from Stanford Kwenda and Caron Griffiths, Pretoria. 

Takes advantage of the fact that Exons already have 0 scores.



Agenda: Day 1
9:30 Welcome

10:00 Basic Analysis with Galaxy 
A worked example demonstrating Galaxy Basics 

10:50 Break

11:10 Basic Analysis (continued)

12:30 Lunch (on your own)

13:30 RNA-Seq Analysis 
Quality Control and Galaxy Workflows

15:30 Break

15:50 RNA-Seq Analysis 
Mapping and Splice Junction Identification

17:00 Done

http://bit.ly/GxyCam2015

http://bit.ly/GxyCam2015


Exons & Repeats: Done?

We now know which exons have repeats, and we have 

that information in a format that can be understood by 

many tools. 

Let's see what those genes do. 



Get the gene

NM_001005239_cds_0_0_chr22_15528159_f



Get the gene

NM_001005239_cds_0_0_chr22_15528159_f

Text Manipulation →
Convert delimiters to TAB

NM    001005239    cds    0    0    chr22    15528159    f



Get the gene

NM_001005239_cds_0_0_chr22_15528159_f

Text Manipulation →
Convert delimiters to TAB

NM    001005239    cds    0    0    chr22    15528159    f

Text Manipulation →
Add Column

NM    001005239    cds    0    0    chr22    15528159    f    _



Get the gene

NM_001005239_cds_0_0_chr22_15528159_f

Text Manipulation →
Convert delimiters to TAB

NM    001005239    cds    0    0    chr22    15528159    f

Text Manipulation →
Add Column

Text Manipulation 
→ Merge Columns

NM    001005239    cds    0    0    chr22    15528159    f    _

NM    001005239    cds    0    0    chr22    15528159    f    _    NM_001005239



NM_001005239

Get the damn gene

NM_001005239_cds_0_0_chr22_15528159_f

Text Manipulation →
Convert delimiters to TAB

NM    001005239    cds    0    0    chr22    15528159    f

Text Manipulation →
Add Column

Text Manipulation 
→ Merge Columns

NM    001005239    cds    0    0    chr22    15528159    f    _

NM    001005239    cds    0    0    chr22    15528159    f    _    NM_001005239

Text Manipulation 
→ Cut



Get the Genes

Remove duplicate gene names 

Text Manipulation → Unique 



Got the Genes: Look for GO Enrichment

Let's see what those genes do. 

http://geneontology.org/

http://geneontology.org/


Dataset: 
Any input, output or intermediate set of data + metadata 

History: 
A series of inputs, analysis steps, intermediate datasets, 

and outputs 
Workflow: 

A series of analysis steps 
Can be repeated with different data

Some Galaxy Terminology



Exons and Repeats History → Reusable Workflow?

• The analysis we just finished was about 

• Human chr22 

• Overlap between exons and repeats 

• But, ... 

• there is nothing inherent in the analysis about 
humans, exons or repeats 

• It is a series of steps that sets the score of one 
set of features to the number of overlaps from 
another set of features.



Extract Workflow from history 

Create a workflow from this history. 
Edit it to make some things clearer. 

          (cog) → Extract Workflow 

Run / test it 
Guided: rerun with same inputs 
     Did that work? 
On your own: 
     Count # of exons in each Repeat 
     Did that work?  Why not? 
      Edit workflow: doc assumptions

Create a Workflow from a History
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RNA-Seq Analysis: Get the Data 

Create new history 

  (cog) → Create New 

Import: 

  Shared Data → Data Libraries → Training → RNA-Seq* 

    → Raw Reads → Select  

              MeOH_REP1_R1, MeOH_REP1_R2 

              MeOH_REP2_R1, MeOH_REP2_R2 

    → Reference 

        → Select all 

* RNA-Seq example datasets from the 2013 UC Davis 
Bioinformatics Short Course.  http://bit.ly/ucdbsc2013

http://bit.ly/ucdbsc2013


NGS Data Quality Control

• FASTQ format 

• Examine quality in an RNA-Seq dataset 

• Trim/filter as we see fit, hopefully without 

breaking anything. 

Quality Control is not sexy. 

But it is vital.



What is FASTQ?

• Specifies sequence (FASTA) and quality scores (PHRED) 

• Text format, 4 lines per entry 

• FASTQ is such a cool standard, there are 3 (or 5) of them!

http://en.wikipedia.org/wiki/FASTQ_format

SSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSS
    ...............................IIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII
    ..........................XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
    !"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`abcdefghijklmnopqrstuvwxyz{|}~
    |                         |    |        |                              |                     |
   33                        59   64       73                            104                   126

   S - Sanger       Phred+33,  93 values  (0, 93) (0 to 60 expected in raw reads)
   I - Illumina 1.3 Phred+64,  62 values  (0, 62) (0 to 40 expected in raw reads)
   X - Solexa       Solexa+64, 67 values (-5, 62) (-5 to 40 expected in raw reads)

   @SEQ_ID
   GATTTGGGGTTCAAAGCAGTATCGATCAAATAGTAAATCCATTTGTTCAACTCACAGTTT
   +
   !''*((((***+))%%%++)(%%%%).1***-+*''))**55CCF>>>>>>CCCCCCC65

http://usegalaxy.org/community


NGS Data Quality: Assessment tools

NGS QC and Manipulation → FastQC 

Generates summary quality information.

http://bit.ly/FastQCBoxPlot

http://bit.ly/FastQCBoxPlot


NGS Data Quality: Assessment tools

http://bit.ly/FastQCBoxPlot

http://bit.ly/FastQCBoxPlot


NGS Data Quality: Sequence bias at front of reads?

From a 

sequence 

specific bias 

that is 

caused by 

use of 

random 

hexamers in 

library 

preparation. 

Hansen, et al., “Biases in Illumina transcriptome sequencing caused by 

random hexamer priming” Nucleic Acids Research, Volume 38, Issue 12 (2010)

http://nar.oxfordjournals.org/cgi/content/abstract/38/12/e131


NGS Data Quality Assessment: Done!

Now, just 11 more to go!



Your Friend: The Multiple datasets button



NGS Data Quality Assessment: 11 more to go!



• Trim as we see fit: Option 1 

• NGS QC and Manipulation → 

FASTQ Trimmer by column 

• Trim same number of columns 

from every record 

• Can specify different trim for 5’ 

and 3’ ends

NGS Data Quality: Trim as we see fit



NGS Data Quality: Base Quality Trimming

• Trim Filter as we see fit: Option 2 

• NGS QC and Manipulation → 

Filter FASTQ reads by quality 

score and length 

• Keep or discard whole reads 

• Can have different thresholds for 

different regions of the reads. 

• Keeps original read length.



NGS Data Quality: Base Quality Trimming

• Trim as we see fit: Option 3 

• NGS QC and Manipulation → 

FASTQ Quality Trimmer by 

sliding window 

• Trim from both ends, using 

sliding windows, until you hit a 

high-quality section. 

• Produces variable length reads



Options are 

not mutually 

exclusive

Option 1 

(by column) 

+ 

Option 2  

(by entire row)



Trim? As we see fit?

• 3 options 

• One preserves original read length, two don’t 

• One preserves number of reads, two don’t 

• Two keep/make every read the same length, one does 

not  

• One preserves pairings, two don't 



• Choice depends on downstream tools  

• Find out assumptions & requirements for downstream 

tools and make appropriate choice(s) now. 

• How to do that? 

• Read the tool documentation 

• http://biostars.org/ 

• http://seqanswers.com/ 

• http://galaxyproject.org/search

Trim? As we see fit?

http://biostars.org
http://seqanswers.com
http://galaxyproject.org/search


Trim? As we see fit?

• 3 options 

• ... 

• One preserves pairings, two don't 



• Don't bother. 

• Run a workflow (try the "Re-Pair Paired ends after QC may 

have broken them" workflow on usegalaxy.org) that 

removes any unpaired reads before mapping 

• Run the Picard Paired Read Mate Fixer after mapping 

reads. 

Keeping paired ends paired: Things to Try



RNA-Seq Analysis: Restore Pairings 

If your QC filters might have broken pairings, then you 

may want to restore them. 

  Shared Data → Published Workflows 

    → Re-Pair Paired ends after QC may have broken them 

      → Import 

And then 

  Workflows  

    → Re-Pair Paired ends after QC may have broken them 

      → Run 



Re-Pair Paired ends after QC may have broken them

Workflow takes 4 inputs 

• Forward Reads, before QC 

• Reverse Reads, before QC 

• Forward Reads, after QC 

• Reverse Reads, after QC 

Workflow assumes pre-QC reads are correctly paired

And produces 4 outputs 

• Forward reads, re-paired 

• Reverse reads, re-paired 

• Forward reads, singletons 

• Reverse reads, singletons 



Re-Pair Paired ends after QC may have broken them



NGS Data Quality: Sequencing Artifacts

And only now we notice a problem with MeOH Rep1 R2 (the 

reverse reads) 

NGS QC and Manipulation → Remove sequencing artifacts 

But this will break pairings (if we still have them). 

Or, can rely on mapper to just not map them.



NGS Quality Control Revisted

"Quality Control is not sexy. 

But it is vital." 

Really? 

Do QC, or rely on bad data not to map?



• Tophat looks for best place(s) to map reads, and 

best places to insert introns  

• Imagine pages and pages of discussion on the 

intricacies and pitfalls of RNA-seq mapping here.

RNA-seq Exercise: Mapping with Tophat2



Expected distance between paired end reads 

• Determined by sample prep 

•  We’ll use 90* for mean inner distance 

• We’ll use 50 for standard deviation 

✴ The library was constructed with the typical Illumina TruSeq protocol, 

which is supposed to have an average insert size of 200 bases. Our reads 

are 55 bases (R1) plus 55 bases (R2). So, the Inner Distance is estimated to 

be 200 - 55 - 55 = 90

From the 2013 UC Davis Bioinformatics Short Course

Mapping with Tophat: mean inner distance

http://nescent.org/


You can bias Tophat towards known annotations 

• Supply your own junction Data? → Yes 

• Use Gene Annotation → Yes 

• Gene Model Annotation → genes_chr12.gtf 

You can also restrict Tophat to known annotations 

• Use Raw Junctions → Yes (tab delimited file) 

• Only look for supplied junctions → Yes

Mapping with Tophat: Use Existing Annotations?



Warning: Here be dragons! 

• Allow indel search → No  

• Use Coverage Search → No  (wee dragons)

Mapping with Tophat: Make it quicker?

TopHat generates its database of possible splice junctions from two sources of evidence. The first 

and strongest source of evidence for a splice junction is when two segments from the same read (for 

reads of at least 45bp) are mapped at a certain distance on the same genomic sequence or when an 

internal segment fails to map - again suggesting that such reads are spanning multiple exons. With 

this approach, "GT-AG", "GC-AG" and "AT-AC" introns will be found ab initio. The second source is 

pairings of "coverage islands", which are distinct regions of piled up reads in the initial mapping. 

Neighboring islands are often spliced together in the transcriptome, so TopHat looks for ways to join 

these with an intron. We only suggest users use this second option (--coverage-search)  for short 

reads (< 45bp) and with a small number of reads (<= 10 million).  This latter option will only report 

alignments across "GT-AG" introns 

TopHat Manual



Some reads align to more than one place equally well. 

For such reads, how many should Tophat include? 

If more than the specified number, Tophat will pick those 

with the best mapping score. 

Tophat breaks ties randomly. 

Tophat assigns equal fractional credit to all n mappings

Mapping with Tophat: Max # of Alignments Allowed

Instructs TopHat to allow up to this many alignments to the reference for a given read, and choose 

the alignments based on their alignment scores if there are more than this number. The default is 20 

for read mapping. Unless you use --report-secondary-alignments, TopHat will report the alignments 

with the best alignment score. If there are more alignments with the same score than this number, 

TopHat will randomly report only this many alignments. In case of using --report-secondary-

alignments, TopHat will try to report alignments up to this option value, and TopHat may randomly 

output some of the alignments with the same score to meet this number. 

TopHat Manual



Mapping With Tophat: Cleanup

Use only the good stuff! 

NGS BAM Tools → Filter 

Mapping Quality → >=20  

Insert Filter → isProperPair: Yes 

Insert Filter → reference: chr12 



Mapping With Tophat: Only 5 more to do!

Hmmm. 

Could use Multiple Datasets feature like we did with FastQC. 

Could also construct workflows. 

Another solution is  

Collections  



RNA-Seq Mapping With Tophat:  Resources

RNA-Seq Concepts, Terminology, and Work Flows  
by Monica Britton 

Aligning PE RNA-Seq Reads to a Genome 
by Monica Britton 

both from the UC Davis 2013 Bioinformatics Short Course 

RNA-Seq Analysis with Galaxy 
by Jeroen F.J. Laros, Wibowo Arindrarto, Leon Mei 

from the GCC2013 Training Day 

RNA-Seq Analysis with Galaxy 

by Curtis Hendrickson, David Crossman, Jeremy Goecks 

from the GCC2012 Training Day 

http://training.bioinformatics.ucdavis.edu/docs/2013/09/short-course-2013/ThuAM-rnaseq-lecture.html
http://training.bioinformatics.ucdavis.edu/docs/2013/09/short-course-2013/ThuPM-PE-tophat.html
http://training.bioinformatics.ucdavis.edu/docs/2013/09/short-course-2013/index.html
http://wiki.galaxyproject.org/Events/GCC2013/TrainingDay%23RNA-Seq_Analysis_with_Galaxy
http://www.lgtc.nl/about_us/lgtc_team.php
http://bow.web.id/
http://ngs.nbic.nl/
http://wiki.galaxyproject.org/Events/GCC2013/TrainingDay
http://wiki.galaxyproject.org/Events/GCC2012/TrainingDay%23WS9
http://wiki.galaxyproject.org/Events/GCC2012/TrainingDay


Agenda: Day 1
9:30 Welcome

10:00 Basic Analysis with Galaxy 
A worked example demonstrating Galaxy Basics 

10:50 Break

11:10 Basic Analysis (continued)

12:30 Lunch (on your own)

13:30 RNA-Seq Analysis 
Quality Control and Galaxy Workflows

15:30 Break

15:50 RNA-Seq Analysis 
Mapping and Splice Junction Identification

17:00 Done

http://bit.ly/GxyCam2015

http://bit.ly/GxyCam2015
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Galaxy Project 
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mailto:outreach@galaxyproject.org?subject=
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RNA-Seq Analysis: Transcript Prediction 

Create new history 

  (cog) → Create New 

Import: 

  Shared Data → Data Libraries → Training → RNA-Seq* 

    → Mapped Filtered Reads 

        → Select all 

    → Reference 

        → Select all 

* RNA-Seq example datasets from the 2013 UC Davis 
Bioinformatics Short Course.  http://bit.ly/ucdbsc2013

http://bit.ly/ucdbsc2013


RNA-Seq Analysis: Collections 



RNA-Seq Analysis: Collections 



RNA-Seq Analysis: Transcript Prediction 

Cufflinks and StringTie are both tools that predict 

transcripts based on mapped reads. 

We'll use StringTie as it's rumoured to be faster and more 

accurate. 

  NGS RNA Analysis → StringTie 

Pertea M, Pertea GM, Antonescu CM, Chang TC, Mendell JT & Salzberg SL. 
StringTie enables improved reconstruction of a transcriptome from RNA-seq 

reads Nature Biotechnology 2015, doi:10.1038/nbt.3122



RNA-Seq Analysis: StringTie 



RNA-Seq Analysis: Transcript Prediction 

NGS RNA Analysis → StringTie 

  Use GFF to guide assembly → Yes 

  Perform abundance information only of input transcripts  

    → No 

  Output additional files for use in Ballgown → No 

  Options → Use defaults



RNA-Seq Analysis: Transcript Prediction 

StringTie outputs: 

  Assembled Transcripts: 

    Transcripts that StringTie successfully assembled  

  Coverage:  

    Reference transcripts that are fully covered by reads



RNA-Seq Analysis: Unify Predictions 

Have transcript predictions from 6 replicates 

Have reference transcripts as well 

Cuffmerge unifies these 7 sets of predictions into a 

single rationalised set of transcripts.  



RNA-Seq Analysis: Transcript Prediction 

Run Cuffmerge 

  NGS RNA Analysis → Cuffmerge 

    Run it with the two assembled transcripts  

       collections from StringTie  

    Use reference Annotation? → Yes 

    Use sequence data? → Yes 

      Source for reference List → History, chr12.fa



Cuffdiff

•Part of the Tuxedo RNA-Seq Suite (as are 

Tophat, Bowtie, StringTie, Cufflinks, 

Cuffmerge, ...) 

• Identifies differential expression between multiple 

datasets 

•Widely used and widely installed on Galaxy 

instances

NGS: RNA Analysis → Cuffdiff



Cuffdiff

Cuffdiff previously used FPKM/RPKM as central statistic.  

Total # mapped reads heavily influences FPKM/RPKM. 

Can lead to challenges when you have very highly expressed 

genes in the mix. 



Cuffdiff

• Which Transcript definitions to use? 

• Official (genes_chr12.gtf in our case) 

• MeOH or R3G Cufflinks transcripts 

• Results of Cuffmerge on MeOH & R3G Cufflinks 

transcripts 

• Depends on what you care about 

• I'll use transcripts from Cuffmerge 



Cuffdiff

• Running with 2 Groups: MeOH and R3G 

• Each group has 3 replicates each



Cuffdiff

Produces many output files, all explained in doc  

We’ll focus on gene differential expression testing



Cuffdiff: differentially expressed genes

Column Contents

test_stat
value of the test statistic used to compute        

significance of the observed change in FPKM

p_value Uncorrected P value for test statistic

q_value FDR-adjusted p-value for the test statistic

status Was there enough data to run the test?

significant and, was the gene differentially expressed?



Cuffdiff

• Column 7 (“status”) can be FAIL, NOTEST, LOWDATA 

or OK 

• Filter and Sort → Filter 

• c7 == 'OK'  

• Column 14 (“significant”) can be yes or no 

• Filter and Sort → Filter 

• c14 == 'yes' 

Returns the list of genes with  

1) enough data to make a call, and  

2) that are called as differentially expressed.



Cuffdiff: Next Steps

Try running Cuffdiff with different normalization and 

dispersion estimation methods.  

Compare the differentially expressed gene lists. 

Which settings have what type of impacts on the results?  

Are there any patterns to the identified genes?
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ChIP-Seq: FASTQ data and quality control 

By Shannan Ho Sui 

Look at two transcription factor  

proteins, Pou5f1 and Nanog,  

in H1hesc cell lines. 

Both are involved in self-renewal of  

undifferentiated embryonic stem cells 

http://hbc.github.io/ngs-workshops/courses/

introduction-to-chip-seq/

H3ABioNet 

http://bit.ly/nanogname



ChIP-Seq Analysis: Get the Data 

Import 

Shared Data → Data Libraries → Training → 

ChIP-Seq → Raw Reads 

H1hesc_Input_Rep1_chr12.fastq 

H1hesc_Input_Rep2_chr12.fastq 



NGS Data Quality: Assessment tools

Same tools available as yesterday:  

FastQC, Sliding window, Trimmer by Column, by 

quality score and length 



• Trim as we see fit: Option 1 

• NGS QC and Manipulation → 

FASTQ Trimmer by column 

• Trim same number of columns 

from every record 

• Can specify different trim for 5’ 

and 3’ ends

NGS Data Quality: Trim as we see fit



NGS Data Quality: Base Quality Trimming

• Trim Filter as we see fit: Option 2 

• NGS QC and Manipulation → 

Filter FASTQ reads by quality 

score and length 

• Keep or discard whole reads 

• Can have different thresholds for 

different regions of the reads. 

• Keeps original read length.



NGS Data Quality: Base Quality Trimming

• Trim as we see fit: Option 3 

• NGS QC and Manipulation → 

FASTQ Quality Trimmer by 

sliding window 

• Trim from both ends, using 

sliding windows, until you hit a 

high-quality section. 

• Produces variable length reads



Trim? As we see fit?

• Introduced 3 options 

• One preserves original read length, two don’t 

• One preserves number of reads, two don’t 

• Two keep/make every read the same length, one 

does not  



Does MACS2 care?  No.

From the MACS Announcement mailing list 

https://groups.google.com/forum/#!topic/macs-announcement/B4HKVn7WXC0NGS


Does MACS2 care?  No

• Trim as we see fit: Option 3 

• NGS QC and Manipulation → 

FASTQ Quality Trimmer by 

sliding window 

• Trim from both ends, using 

sliding windows, until you hit a 

high-quality section. 

• Produces variable length reads



ChIP-Seq Analysis: Get the Data 

Shared Data → Data Libraries → Training → 

ChIP-Seq 

Select everything in the Filtered Reads folder 

Also grab genes_chr12.gtf from  

library



Use Bowtie2 (could also use BWA) 

NGS Mapping: → Bowtie2 

FASTQ file → H1hesc_Nanog_Rep1 post-QC 

Single End 

ChIP-Seq Exercise: Mapping with Bowtie



NGS Picard → FilterSamReads 

Filtering Type → Include Aligned 

ChIP-Seq Analysis: remove unmapped reads



ChIP-Seq Analysis: Get the Data 

Shared Data → Data Libraries → Training → 

ChIP-Seq 

Select everything in the Mapped Reads folder 

(These already have unmapped removed.)



NGS: ChIP-seq → MACS2 callpeak 

Treatment File → Nanog Rep 1 

Control File → H1hesc_Input_Rep2_chr12 Mapped BAM file 

Outputs → Peaks, Scores 

https://github.com/taoliu/MACS/

ChIP-Seq Analysis: Find Peaks

https://github.com/taoliu/MACS/


Shared Data → Data Libraries → Training → ChIP-Seq →  

    MACS Outputs → Peaks in BED format 

Import files for  

Nanog Rep 2 

Pou5f1 Rep 1  

Pou5f1 Rep 2  

        (or just get all 4)

ChIP-Seq Analysis: Replicates



Operate on Genomic Intervals → Concatenate 

Concatenate Nanog Rep 1 and 2 peak files 

Operate on Genomic Intervals → Cluster  

Use default parameters 

Rename the output dataset 

ChIP-Seq Analysis: Unify Replicates



Repeat for Pou5f1 replicates 

Operate on Genomic Intervals → Concatenate 

Concatenate Pou5f1 Rep 1 and 2 Peak files 

Operate on Genomic Intervals → Cluster  

Use default parameters 

Rename the output dataset 

ChIP-Seq Analysis: Unify Replicates



Operate on Genomic Intervals → Subtract 

First dataset clustered → Pou5f1 

Second dataset clustered → Nanog 

Return → Intervals with no overlap

ChIP-Seq Analysis: Differential binding



ChIP-Seq Mapping With MACS 
 Further reading & Resources

ChIP-Seq: FASTQ data and quality control 

by Shannan Ho Sui 

 HAIB TFBS ENCODE collection 

MACS Documentation 

Model-based analysis of ChIP-Seq (MACS) 
by Zhang et al. 

Cistrome and Nebula Galaxy Servers 

Nebula Tutorial 
by Valentina Boeva

http://scriptogr.am/ohofmann/post/chip-seq-fastq-data-and-quality-control
http://hgdownload.cse.ucsc.edu/goldenpath/hg19/encodeDCC/wgEncodeHaibTfbs/
http://liulab.dfci.harvard.edu/MACS/00README.html.%0A%0Ahttp://liulab.dfci.harvard.edu/MACS/00README.html.%0A%0A
http://www.ncbi.nlm.nih.gov/pubmed/18798982
http://cistrome.org
http://nebula.curie.fr/
http://nebula.curie.fr/static/nebula_tutorial.pdf


Agenda: Day 2
9:30 RNA-Seq Analysis 

Differential expression 

10:50 Break

11:10 RNA-Seq Analysis 
continued 

12:30 Lunch (on your own)

13:30 ChIP-Seq Analysis 
Quality Control and Mapping

15:00 Break

15:20 ChIP-Seq Analysis 
Differential Binding and Comparing Results

16:30 Done (almost)

http://bit.ly/GxyCam2015

http://bit.ly/GxyCam2015


Your Feedback: We need it

http://bit.ly/GxyCamFeedback



Dannon Baker Dan Blankenberg Dave Bouvier

http://wiki.galaxyproject.org/GalaxyTeam

Enis Afgan John Chilton

Nate Coraor Carl Eberhard Jeremy Goecks

Ross Lazarus Anton Nekrutenko James Taylor

The Galaxy Team

Jen Jackson

Sam GuerlerDave Clements

Nick Stoler

Marten Cech

Nitesh Turaga

http://bit.ly/GxyCamFeedback



http://wiki.galaxyproject.org/GalaxyIsHiring

Galaxy is hiring post-docs and software engineers 

Please help.

http://galaxyproject.org/wiki/GalaxyTeam


Gabriella Rustici 

Paul Judge 

Cathy Hemmings 

Anne Pajon 

& 

You 

Also thanks to

http://bit.ly/GxyCamFeedback



Agenda: Day 2
9:30 RNA-Seq Analysis 

Differential expression 

10:50 Break

11:10 RNA-Seq Analysis 
continued 

12:30 Lunch (on your own)

13:30 ChIP-Seq Analysis 
Quality Control and Mapping

15:00 Break

15:20 ChIP-Seq Analysis 
Differential Binding and Comparing Results

16:30 Done

http://bit.ly/GxyCam2015

http://bit.ly/GxyCam2015


Thanks

Dave Clements 

Galaxy Project 

Johns Hopkins University 

clements@galaxyproject.org 

http://bit.ly/GxyCamFeedback

mailto:outreach@galaxyproject.org?subject=

