
http://bit.ly/glaxy2015slides

http://bit.ly/gxyXXXX


Introduction to Galaxy

University of Glasgow 

8-9 June 2015 

Dave Clements  

   Galaxy Project 

   Johns Hopkins University 

Mani Mudaliar  

   Glasgow Polyomics 

   University of Glasgow 

Graham Hamilton 

   Glasgow Polyomics 

   University of Glasgow 



Agenda: Day 1
9:00 Welcome

9:30 Basic Analysis with Galaxy 

10:45   Break

11:15 Basic Analysis (continued)

12:00 Basic Analysis into Reusable Workflows

12:30   Lunch (on your own)

13:30 ChIP-Seq Analysis 

15:30   Break

16:00 Genome Assembly Concepts

16:30 Q & A Session

17:00   Done

http://bit.ly/glaxy2015slides

http://bit.ly/glaxy2015slides


Goals

Provide a basic introduction to using Galaxy for 

bioinformatic analysis. 

Demonstrate how Galaxy can help you explore and 

learn options, perform analysis, and then share, 

repeat, and reproduce your analyses.

http://bit.ly/glaxy2015slides

http://bit.ly/glaxy2015slides


This workshop will not cover  

• details of how tools are implemented, or 

• new algorithm designs, or 

• which assembler or mapper or peak caller or ... is 

best for you. 

This workshop does cover ChIP-Seq, RNA-Seq, variant 

analysis, .... However, you won't be an expert at any of 

these at the end of the workshop. 

You will know enough to get you started.

Not Goals



What is Galaxy?

Data integration and analysis platform that 

emphasizes accessibility, reproducibility, and 

transparency  

http://galaxyproject.org

http://gmod.org/wiki/Computing_Requirements


Galaxy is available online, for free

http://usegalaxy.org  

As a free (for everyone) web server integrating a 

wealth of tools, compute resources, petabytes of 

reference data and permanent storage 

However, a centralized solution cannot support 

the different analysis needs of the entire world.

http://usegalaxy.org


Galaxy is available as Open Source Software

Galaxy is installed in locations around the world. 

Some of them are free for anyone to use too. 

http://getgalaxy.org 

bit.ly/gxyServers

http://usegalaxy.org
http://bit.ly/gxyServers


http://aws.amazon.com/education 

http://globus.org/ 

http://wiki.galaxyproject.org/Cloud 

We are using the cloud today.

Galaxy is available on the Cloud

http://usegalaxy.org/cloud
http://wiki.galaxyproject.org/Cloud


Galaxy is available with Commercial Support

A ready-to-use appliance 

(BioTeam) 

Cloud-based solutions 

(ABgenomica, AIS, 

GenomeCloud) 

Consulting & Customization 

(BioTeam, Deena 

Bioinformatics) 

Training  

(OpenHelix)



Galaxy Project: Further reading & Resources

http://galaxyproject.org 

http://usegalaxy.org 

http://getgalaxy.org 

http://wiki.galaxyproject.org/Cloud 

http://bit.ly/gxychoices

http://wiki.galaxyproject.org/Cloud
http://bit.ly/gxychoices


Agenda: Day 1
9:00 Welcome

9:30 Basic Analysis with Galaxy 

10:45   Break

11:15 Basic Analysis (continued)

12:00 Basic Analysis into Reusable Workflows

12:30   Lunch (on your own)

13:30 ChIP-Seq Analysis 

15:30   Break

16:00 Genome Assembly Concepts

16:30 Q & A Session

17:00   Done



Basic Analysis

Which exons have most overlapping 

Repeats? 

Use Human, HG38, Chromosome 22 

test.galaxyproject.org 

(~ http://usegalaxy.org/galaxy101 )

http://test.galaxyproject.org
http://usegalaxy.org/galaxy101


Exons & Repeats: A General Plan

• Get some data 

• Get Data → UCSC Table Browser 

• Identify which exons have Repeats 

• Count Repeats per exon 

• Visualize, save, download, ... exons with 

most Repeats

(~ http://usegalaxy.org/galaxy101 )

http://usegalaxy.org/galaxy101


(Identify which exons have Repeats) 

Exons Repeats



Operate on Genomic Intervals → Join 

(Identify which exons have Repeats)

Exons Repeats

Exons

Repeats

Overlap pairings



Exons Repeats

1

1

2

Exons

Repeats

Overlap pairings

Exon overlap counts

Join, Subtract, and Group → Group  

(Count Repeats per exon)



Exons

1

1

2

Exon overlap counts

We’ve answered our question, but we can do better. 

Incorporate the overlap count with rest of Exon information 



Exons

1

1

2

Exon overlap counts

1

1

2
Join on exon name

0

0

0

Join, Subtract, and Group →Join 

(Incorporate the overlap count with rest of Exon information) 



Exons

1

1

2

Exon overlap counts

1

1

2
Join on exon name

0

0

0

1

1

2

Rearrange columns w/ 

cut

Text Manipulation →Cut 

(Incorporate the overlap count with rest of Exon information) 
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Exons & Repeats: Exercise

Include exons with no overlaps in final output. 

Set the score for these to 0. 

Everything you need will be in the toolboxes we used 

in the Exon-Repeats exercise. 



One Possible Solution

Solution from Stanford Kwenda and Caron Griffiths, Pretoria. 

Takes advantage of the fact that Exons already have 0 scores.
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Exons & Repeats: Done?

We now know which exons have repeats, and we have 

that information in a format that can be understood by 

many tools. 

Let's see what those genes do. 



Get the gene

NM_001005239_cds_0_0_chr22_15528159_f



Get the gene

NM_001005239_cds_0_0_chr22_15528159_f

Text Manipulation →
Convert delimiters to TAB

NM    001005239    cds    0    0    chr22    15528159    f



Get the gene

NM_001005239_cds_0_0_chr22_15528159_f

Text Manipulation →
Convert delimiters to TAB

NM    001005239    cds    0    0    chr22    15528159    f

Text Manipulation →
Add Column

NM    001005239    cds    0    0    chr22    15528159    f    _



Get the gene

NM_001005239_cds_0_0_chr22_15528159_f

Text Manipulation →
Convert delimiters to TAB

NM    001005239    cds    0    0    chr22    15528159    f

Text Manipulation →
Add Column

Text Manipulation 
→ Merge Columns

NM    001005239    cds    0    0    chr22    15528159    f    _

NM    001005239    cds    0    0    chr22    15528159    f    _    NM_001005239



NM_001005239

Get the gene

NM_001005239_cds_0_0_chr22_15528159_f

Text Manipulation →
Convert delimiters to TAB

NM    001005239    cds    0    0    chr22    15528159    f

Text Manipulation →
Add Column

Text Manipulation 
→ Merge Columns

NM    001005239    cds    0    0    chr22    15528159    f    _

NM    001005239    cds    0    0    chr22    15528159    f    _    NM_001005239

Text Manipulation 
→ Cut



Get the Genes

Still not done 

Text Manipulation → Unique 



Got the Genes: Look for GO Enrichment

Let's see what those genes do. 

http://geneontology.org/

http://geneontology.org/
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Dataset: 
Any input, output or intermediate set of data + metadata 

History: 
A series of inputs, analysis steps, intermediate datasets, 

and outputs 
Workflow: 

A series of analysis steps 
Can be repeated with different data

Some Galaxy Terminology



Exons and Repeats History → Reusable Workflow?

• The analysis we just finished was about 

• Human chr22 

• Overlap between exons and repeats 

• But, ... 

• there is nothing inherent in the analysis about 
humans, exons or repeats 

• It is a series of steps that sets the score of one 
set of features to the number of overlaps from 
another set of features.



Extract Workflow from history 

Create a workflow from this history. 
Edit it to make some things clearer. 

          (cog) → Extract Workflow 

Run / test it 
Guided: rerun with same inputs 
     Did that work? 
On your own: 
     Count # of exons in each Repeat 
     Did that work?  Why not? 
      Edit workflow: doc assumptions

Create a Workflow from a History
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ChIP-Seq: FASTQ data and quality control 

By Shannan Ho Sui 

Look at two transcription factor  

proteins, Pou5f1 and Nanog,  

in H1hesc cell lines. 

Both are involved in self-renewal of  

undifferentiated embryonic stem cells 

http://hbc.github.io/ngs-workshops/courses/

introduction-to-chip-seq/

H3ABioNet 



ChIP-Seq Analysis: Get the Data 

Import 

Shared Data → Data Libraries → Training → 

ChIP-Seq → Raw Reads 

H1hesc_Input_Rep1_chr12.fastq 



NGS Data Quality Control

• FASTQ format 

• Examine quality in an Chip-Seq dataset 

• Trim/filter as we see fit, hopefully without 

breaking anything. 

Quality Control is not sexy. 

But it is vital.



What is FASTQ?

• Specifies sequence (FASTA) and quality scores (PHRED) 

• Text format, 4 lines per entry 

• FASTQ is such a cool standard, there are 3 (or 5) of them!

http://en.wikipedia.org/wiki/FASTQ_format

SSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSS
    ...............................IIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII
    ..........................XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
    !"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`abcdefghijklmnopqrstuvwxyz{|}~
    |                         |    |        |                              |                     |
   33                        59   64       73                            104                   126

   S - Sanger       Phred+33,  93 values  (0, 93) (0 to 60 expected in raw reads)
   I - Illumina 1.3 Phred+64,  62 values  (0, 62) (0 to 40 expected in raw reads)
   X - Solexa       Solexa+64, 67 values (-5, 62) (-5 to 40 expected in raw reads)

   @SEQ_ID
   GATTTGGGGTTCAAAGCAGTATCGATCAAATAGTAAATCCATTTGTTCAACTCACAGTTT
   +
   !''*((((***+))%%%++)(%%%%).1***-+*''))**55CCF>>>>>>CCCCCCC65

http://usegalaxy.org/community


NGS Data Quality: Assessment tools

NGS QC and Manipulation → FastQC 

Gives you a lot of information but little control over 

how it is calculated or presented.

http://bit.ly/FastQCBoxPlot

http://bit.ly/FastQCBoxPlot


NGS Data Quality: Sequence bias at front of reads?

From a 

sequence 

specific bias 

that is 

caused by 

use of 

random 

hexamers in 

library 

preparation. 

Hansen, et al., “Biases in Illumina transcriptome sequencing caused by 

random hexamer priming” Nucleic Acids Research, Volume 38, Issue 12 (2010)

http://nar.oxfordjournals.org/cgi/content/abstract/38/12/e131


• Trim as we see fit: Option 1 

• NGS QC and Manipulation → 

FASTQ Trimmer by column 

• Trim same number of columns 

from every record 

• Can specify different trim for 5’ 

and 3’ ends

NGS Data Quality: Trim as we see fit



NGS Data Quality: Base Quality Trimming

• Trim Filter as we see fit: Option 2 

• NGS QC and Manipulation → 

Filter FASTQ reads by quality 

score and length 

• Keep or discard whole reads 

• Can have different thresholds for 

different regions of the reads. 

• Keeps original read length.



NGS Data Quality: Base Quality Trimming

• Trim as we see fit: Option 3 

• NGS QC and Manipulation → 

FASTQ Quality Trimmer by 

sliding window 

• Trim from both ends, using 

sliding windows, until you hit a 

high-quality section. 

• Produces variable length reads



Options are 

not mutually 

exclusive

Option 1 

(by column) 

+ 

Option 2  

(by entire row)



Trim? As we see fit?

• Introduced 3 options 

• One preserves original read length, two don’t 

• One preserves number of reads, two don’t 

• Two keep/make every read the same length, one does 

not  



• Choice depends on downstream tools  

• Find out assumptions & requirements for downstream 

tools and make appropriate choice(s) now. 

• How to do that? 

• Read the tool documentation 

• http://biostars.org/ 

• http://seqanswers.com/ 

• http://galaxyproject.org/search

Trim? As we see fit?

http://biostars.org
http://seqanswers.com
http://galaxyproject.org/search


Does MACS2 care?  No.

From the MACS Announcement mailing list 

https://groups.google.com/forum/#!topic/macs-announcement/B4HKVn7WXC0NGS


Does MACS2 care?  No

• Trim as we see fit: Option 3 

• NGS QC and Manipulation → 

FASTQ Quality Trimmer by 

sliding window 

• Trim from both ends, using 

sliding windows, until you hit a 

high-quality section. 

• Produces variable length reads



NGS Data Quality: Further reading & Resources

FastQC Documenation 

Read Quality Assessment & Improvement  
by Joe Fass 

From the UC Davis 2013 Bioinformatics Short Course 

Manipulation of FASTQ data with Galaxy 
by Blankenberg, et al.

http://www.bioinformatics.babraham.ac.uk/projects/fastqc/Help/3%2520Analysis%2520Modules/
http://training.bioinformatics.ucdavis.edu/docs/2013/09/short-course-2013/MonAM-readQAI-lecture.html
http://training.bioinformatics.ucdavis.edu/docs/2013/09/short-course-2013/index.html
http://bioinformatics.oxfordjournals.org/cgi/pmidlookup?view=long&pmid=20562416


ChIP-Seq Analysis: Get the Data 

Shared Data → Data Libraries → Training → 

ChIP-Seq 

Select everything in the Filtered Reads folder 

Also grab genes_chr12.gtf from  

library



Use Bowtie2 (could also use BWA) 

NGS Mapping: → Bowtie2 

FASTQ file → H1hesc_Nanog_Rep1 post-QC 

Single End 

ChIP-Seq Exercise: Mapping with Bowtie



NGS Picard → FilterSamReads 

Filtering Type → Include Aligned 

ChIP-Seq Analysis: remove unmapped reads



NGS: ChIP-seq → MACS2 callpeak 

Treatment File → Nanog Rep 1 

Control File → Nanog Rep2 BAM file 

Control File → H1hesc_Input_Rep2_chr12 Mapped BAM file 

Outputs → Everything except summits 

https://github.com/taoliu/MACS/

ChIP-Seq Analysis: Find Peaks

https://github.com/taoliu/MACS/


Shared Data → Data Libraries → Training → ChIP-Seq →  

       Reference → genes_chr12.gtf 

Launch a Trackster visualization and bring in  

the Peaks in BED format 

the Bedgraph Treatment  

the Bedgraph Control  

the gene definitions 

ChIP-Seq Analysis: Visualize Results



Shared Data → Data Libraries → Training → ChIP-Seq →  

    MACS Outputs → Peaks in BED format 

Import files for  

Nanog Rep 2 

Pou5f1 Rep 1  

Pou5f1 Rep 2  

ChIP-Seq Analysis: Replicates



Operate on Genomic Intervals → Concatenate 

Concatenate Nanog Rep 1 and 2 peak files 

Operate on Genomic Intervals → Cluster  

Use default parameters 

Rename the output dataset 

Add the Nanog cluster output to your visualization

ChIP-Seq Analysis: Unify Replicates



Repeat for Pou5f1 replicates 

Operate on Genomic Intervals → Concatenate 

Concatenate Pou5f1 Rep 1 and 2 Peak files 

Operate on Genomic Intervals → Cluster  

Use default parameters 

Rename the output dataset 

Add the Pou5f1 cluster output to your visualization

ChIP-Seq Analysis: Unify Replicates



Operate on Genomic Intervals → Subtract 

First dataset clustered → Pou5f1 

Second dataset clustered → Nanog 

Return → Intervals with no overlap

ChIP-Seq Analysis: Differential binding



ChIP-Seq Mapping With MACS 
 Further reading & Resources

ChIP-Seq: FASTQ data and quality control 

by Shannan Ho Sui 

 HAIB TFBS ENCODE collection 

MACS Documentation 

Model-based analysis of ChIP-Seq (MACS) 
by Zhang et al. 

Cistrome and Nebula Galaxy Servers 

Nebula Tutorial 
by Valentina Boeva

http://scriptogr.am/ohofmann/post/chip-seq-fastq-data-and-quality-control
http://hgdownload.cse.ucsc.edu/goldenpath/hg19/encodeDCC/wgEncodeHaibTfbs/
http://liulab.dfci.harvard.edu/MACS/00README.html.%0A%0Ahttp://liulab.dfci.harvard.edu/MACS/00README.html.%0A%0A
http://www.ncbi.nlm.nih.gov/pubmed/18798982
http://cistrome.org
http://nebula.curie.fr/
http://nebula.curie.fr/static/nebula_tutorial.pdf
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even more encouragement from Ekblom & Wolf

• it is essentially impossible to sequence and 

assemble all nucleotides in the genome 

(Ellengren 2014) 

• there will also be some degree of error in the 

characterized genome sequence 

• every genome assembly is the result of a 

series of assembly heuristics and should 

accordingly be treated as a working 

hypothesis 

• it is often not realistic to aim for a 

chromosome level assembly



Best Practices

• Use several libraries covering different and 

longer insert sizes 

• If using only short reads, ~100x coverage 

is needed.  Suggested breakdown for 

mammals: 

• 45x coverage with short insert 

• 45x coverage with medium insert (3-10kb) 

• 1-5x coverage  with long insert (10-40kb) 

• From Nagarajan and Pop, 2013



Best Practices

• Estimate genome size, sequencing error 

rates, repeat content and amount of 

genome duplication 

• Can perform a pilot study to get these 

estimates. 

• More repeats or duplication mean higher 

coverage 

• Use inbred, parthenogenic or gynogenetic 

individuals.  Heterozygosity is not your 

friend.



Scaffolding 

Want to tie together those contigs into larger units called 

scaffolds. 

Some software solutions for this. 

Can also use related genomes. 

Get more reads, possibly on a different platform,  

or different insert length. 

These can be provided at initial assembly time.

NGS Assembly: What next?



NGS Assembly: 

What’s better?



Beginner’s guide to comparative bacterial genome 

analysis using next-generation sequence data   

Bacterial Comparative Genomics Tutorial  

By David J Edwards and Kathryn E Holt 

Assemblathon 2: evaluating de novo methods of genome 

assembly in three vertebrate species 

Bradnam, et al. 

Whole Genome Assembly and Alignment 

Michael Schatz

NGS Assembly: Resources and Reading

http://www.microbialinformaticsj.com/content/3/1/2/
http://www.microbialinformaticsj.com/imedia/1627516282963968/supp1.pdf
http://www.gigasciencejournal.com/content/2/1/10
http://schatzlab.cshl.edu/teaching/2012/CSHL.Sequencing/Whole%2520Genome%2520Assembly%2520and%2520Alignment.pdf
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Thanks

Dave Clements 

Galaxy Project 

Johns Hopkins University 

clements@galaxyproject.org 

http://bit.ly/glaxy2015slides

mailto:outreach@galaxyproject.org?subject=

