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The Agenda

9:00 Introduction

9:30 Getting Our Hands Dirty: A worked ChIP-Seq 

example

10:50 Break

11:10 Getting Our Hands Dirtier, continued

12:30 Lunch

13:30 RNA-Seq Worked Example

14:40 Break

15:00 RNA-Seq Worked Example, continue

16:30 Done



The Agenda

Goal is to demonstrate how Galaxy can help you 

explore and learn options, perform analysis, and then 

share, repeat, and reproduce your analyses.



This workshop will not cover  

• details of how tools are implemented, or 

• new algorithm designs, or 

• which assembler or mapper or peak caller or ... is 

best for you. 

!

While this workshop does cover ChIP-Seq and RNA-Seq, 

we are only using that specific example to learn general 

principles. 

Not The Agenda



What is Galaxy?

!

A free (for everyone) web server 

Open source software 

These options result in several ways to use Galaxy

http://galaxyproject.org

http://gmod.org/wiki/Computing_Requirements


Galaxy is available ...

As a free (for everyone) web server integrating a 

wealth of tools, compute resources, terabytes of 

reference data and permanent storage  

!

http://usegalaxy.org

However, a centralized solution cannot support 

the different analysis needs of the entire world.

http://usegalaxy.org


Leveraging the national cyberinfrastructure for biomedical research 

LeDuc, et al. J Am Med Inform Assoc doi:10.1136/amiajnl-2013-002059



Galaxy is available ...

•As a free (for everyone) web service  

http://usegalaxy.org  

•As open source software  

http://getgalaxy.org 

It is installed in locations around the world, 

including IGMM 

http://usegalaxy.org
http://usegalaxy.org


Galaxy is available ...

•As a free (for everyone) web service  

http://usegalaxy.org  

•As open source software  

http://getgalaxy.org 

•On the Cloud 

We are using this today.  

http://aws.amazon.com/education 

http://globus.org/ 

!

http://wiki.galaxyproject.org/Cloud

http://usegalaxy.org
http://usegalaxy.org
http://usegalaxy.org/cloud
http://wiki.galaxyproject.org/Cloud


Galaxy is available: With Commercial Support

A ready-to-use appliance 

(BioTeam) 

Cloud-based solutions 

(ABgenomica, AIS, Appistry, 

GenomeCloud) 

Consulting & Customization 

(Arctix, BioTeam, Deena 

Bioinformatics)



Galaxy Project: Further reading & Resources

http://galaxyproject.org 

http://usegalaxy.org 

http://getgalaxy.org 

http://wiki.galaxyproject.org/Cloud 

http://bit.ly/gxychoices

http://wiki.galaxyproject.org/Cloud
http://bit.ly/gxychoices
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http://cloud1.galaxyproject.org/ 

http://cloud2.galaxyproject.org/ 

http://cloud3.galaxyproject.org/ 

http://cloud4.galaxyproject.org/ 



ChIP-Seq: FASTQ data and quality control 

http://scriptogr.am/ohofmann 

By Shannan Ho Sui 

!

Look at two transcription factor  

proteins, Pou5f1 and Nanog,  

in H1hesc cell lines. 

!

Both are involved in self-renewal of  

undifferentiated embryonic stem cells.

H3ABioNet 



ChIP-Seq Analysis: Get the Data 

!

Import 

Shared Data → Data Libraries → 

ChIP-Seq Datasets  → Unfiltered Reads 

H1hesc_Input_Rep1_chr12_unfiltered.fastq 

!



NGS Data Quality Control

• FASTQ format 

• Examine quality in an Chip-Seq dataset 

• Trim/filter as we see fit, hopefully without 

breaking anything. 

!

Quality Control is not sexy. 

It is vital.



What is FASTQ?

• Specifies sequence (FASTA) and quality scores (PHRED) 

• Text format, 4 lines per entry 

!

!

• FASTQ is such a cool standard, there are 3 (or 5) of them!

http://en.wikipedia.org/wiki/FASTQ_format

!
SSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSS!

    ...............................IIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII!
    ..........................XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX!
    !"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`abcdefghijklmnopqrstuvwxyz{|}~!
    |                         |    |        |                              |                     |!
   33                        59   64       73                            104                   126!
!
   S - Sanger       Phred+33,  93 values  (0, 93) (0 to 60 expected in raw reads)!
   I - Illumina 1.3 Phred+64,  62 values  (0, 62) (0 to 40 expected in raw reads)!
   X - Solexa       Solexa+64, 67 values (-5, 62) (-5 to 40 expected in raw reads)!

   @SEQ_ID!
   GATTTGGGGTTCAAAGCAGTATCGATCAAATAGTAAATCCATTTGTTCAACTCACAGTTT!
   +!
   !''*((((***+))%%%++)(%%%%).1***-+*''))**55CCF>>>>>>CCCCCCC65!

http://usegalaxy.org/community


NGS Data Quality: Assessment tools

NGS QC and Manipulation → FastQC 

Gives you a lot a lot of information but little control 

over how it is calculated or presented.

http://bit.ly/FastQCBoxPlot

http://bit.ly/FastQCBoxPlot


NGS Data Quality: Sequence bias at front of reads?

From a 

sequence 

specific bias 

that is 

caused by 

use of 

random 

hexamers in 

library 

preparation. 

Hansen, et al., “Biases in Illumina transcriptome sequencing caused by 

random hexamer priming” Nucleic Acids Research, Volume 38, Issue 12 (2010)

http://nar.oxfordjournals.org/cgi/content/abstract/38/12/e131


• Trim as we see fit: Option 1 

• NGS QC and Manipulation → 

FASTQ Trimmer by column 

• Trim same number of columns 

from every record 

• Can specify different trim for 5’ 

and 3’ ends

NGS Data Quality: Trim as we see fit



NGS Data Quality: Base Quality Trimming

• Trim Filter as we see fit: Option 2 

• NGS QC and Manipulation → 

Filter FASTQ reads by quality 

score and length 

• Keep or discard whole reads 

• Can have different thresholds for 

different regions of the reads. 

• Keeps original read length.



NGS Data Quality: Base Quality Trimming

• Trim as we see fit: Option 3 

• NGS QC and Manipulation → 

FASTQ Quality Trimmer by 

sliding window 

• Trim from both ends, using 

sliding windows, until you hit a 

high-quality section. 

• Produces variable length reads



Options are 

not mutually 

exclusive

Option 1 

(by column) 

!

+ 

!

Option 2  

(by entire row)



Trim? As we see fit?

• Introduced 3 options 

• One preserves original read length, two don’t 

• One preserves number of reads, two don’t 

• Two keep/make every read the same length, one does 

not  



• Choice depends on downstream tools  

• Find out assumptions & requirements for downstream 

tools and make appropriate choice(s) now. 

• How to do that? 

• Read the tool documentation 

• http://biostars.org/ 

• http://seqanswers.com/ 

• http://galaxyproject.org/search

Trim? As we see fit?

http://biostars.org
http://seqanswers.com
http://galaxyproject.org/search


Does MACS care?  Maybe

• Trim Filter as we see fit: Option 2 

• NGS QC and Manipulation → 

Filter FASTQ reads by quality 

score and length 

• Keep or discard whole reads 

• Can have different thresholds for 

different regions of the reads. 

• Keeps original read length.



NGS Data Quality: Further reading & Resources

FastQC Documenation 
!

Read Quality Assessment & Improvement  
by Joe Fass 

From the UC Davis 2013 Bioinformatics Short Course 

!

Manipulation of FASTQ data with Galaxy 
by Blankenberg, et al.

http://www.bioinformatics.babraham.ac.uk/projects/fastqc/Help/3%2520Analysis%2520Modules/
http://training.bioinformatics.ucdavis.edu/docs/2013/09/short-course-2013/MonAM-readQAI-lecture.html
http://training.bioinformatics.ucdavis.edu/docs/2013/09/short-course-2013/index.html
http://bioinformatics.oxfordjournals.org/cgi/pmidlookup?view=long&pmid=20562416
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ChIP-Seq Analysis: Get the Data 

!

Shared Data → Data Libraries → 

ChIP-Seq Datasets 

Select everything in the Filtered Reads folder 

!

Also grab genes_chr12.gtf from  

library



!

Use Bowtie2 (could also use BWA) 

NGS Mapping: → Bowtie2 

FASTQ file → H1hesc_Nanog_Rep1_chr12_qualityfiltered 

Single End 

ChIP-Seq Exercise: Mapping with Bowtie



!

Convert BAM to SAM 

SAM Tools → SAM-to-BAM 

ChIP-Seq Exercise: Mapping with Bowtie



!

SAM Tools → Filter SAM 

• Click Add a new Flag 

• Set Type to The read is unmapped  

• Set flag state to No. 

!

ChIP-Seq Analysis: remove unmapped reads



!

SAM Tools → SAM-to-BAM 

!

Get the the control (already mapped for us) 

Shared Data → Data Libraries → Aligned → Import 

H1hesc_Input_Rep1_Chr12_Mapped into current 

history

ChIP-Seq Analysis: Put mapped reads in BAM



NGS: Peak Calling → MACS 

Experiment name → MACS NanogRep1 

Tag File → Nanog Rep1 BAM file 

Control File → H1hesc_Input_Rep1_Chr12_aln BAM file 

Tag Size → 36 

Leave MFOLD → 32 

Save shifted raw tag count ... → Save (leave resolution at 10) 

Check Perform the new peak detection method (futuredir)

ChIP-Seq Analysis: Find Peaks



!

Look at the HTML report dataset 

!

Launch a Trackster visualization and bring in  

the called peaks 

the Treatment WIG 

the Control WIG  

the gene definitions 

ChIP-Seq Analysis: Visualize Results



!

Shared Data → Data Libraries → ChIP-Seq Datasets → 

MACS Outputs 

Import Peaks files for  

Nanog Rep 2 

Pou5f1 Rep 1  

Pou5f1 Rep 2  

ChIP-Seq Analysis: Replicates



!

Operate on Genomic Intervals → Concatenate 

Concatenate Nanog Rep 1 and 2 peak files 

!

Operate on Genomic Intervals → Cluster  

Use default parameters 

Rename the output dataset 

!

Add the Nanog cluster output to your visualization

ChIP-Seq Analysis: Unify Replicates



Repeat for Pou5f1 replicates 

Operate on Genomic Intervals → Concatenate 

Concatenate Pou5f1 Rep 1 and 2 Peak files 

!

Operate on Genomic Intervals → Cluster  

Use default parameters 

Rename the output dataset 

!

Add the Pou5f1 cluster output to your visualization

ChIP-Seq Analysis: Unify Replicates



Operate on Genomic Intervals → Subtract 

First dataset clustered → Pou5f1 

Second dataset clustered → Nanog 

Return → Intervals with no overlap

ChIP-Seq Analysis: Differential binding



ChIP-Seq Mapping With MACS 
 Further reading & Resources

ChIP-Seq: FASTQ data and quality control 

by Shannan Ho Sui 
!

 HAIB TFBS ENCODE collection 
!

MACS Documentation 
!

Model-based analysis of ChIP-Seq (MACS) 
by Zhang et al. 

!

Cistrome and Nebula Galaxy Servers 
!

Nebula Tutorial 
by Valentina Boeva

http://scriptogr.am/ohofmann/post/chip-seq-fastq-data-and-quality-control
http://hgdownload.cse.ucsc.edu/goldenpath/hg19/encodeDCC/wgEncodeHaibTfbs/
http://liulab.dfci.harvard.edu/MACS/00README.html.%0A%0Ahttp://liulab.dfci.harvard.edu/MACS/00README.html.%0A%0A
http://www.ncbi.nlm.nih.gov/pubmed/18798982
http://cistrome.org
http://nebula.curie.fr/
http://nebula.curie.fr/static/nebula_tutorial.pdf
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RNA-Seq Exercise

Create new history 

         (cog) → Create New 

Get some data 

        Shared Data → Data Libraries  

 → RNA-Seq Example* 

   → Untrimmed FASTQ 

     → Select MeOH_REP1_R1, MeOH_REP1_R2  

           and then Import to current history 

* RNA-Seq example datasets from the 2013 UC Davis 
Bioinformatics Short Course.  http://bit.ly/ucdbsc2013

http://bit.ly/ucdbsc2013


Trim? As we see fit?

The 3 options introduced earlier 

• One preserves original read length, two don’t 

• One preserves number of reads, two don’t 

• Two keep/make every read the same length, one does 

not  

• One preserves pairings, two don’t



“Mixing paired- and single- end reads together is 

not supported.”              Tophat Manual 
!

!

“If you are performing RNA-seq analysis, there is no 

need to filter the data to ensure exact pairs before 

running Tophat.”                             Jen Jackson 

            Galaxy User Support Person Extraordinaire 
!

“Dang.”                              Most of us 

!
!

!

Running Tophat on no-longer-cleanly-paired data does 

map the reads, but, it no longer keeps track of read pairs 

in the SAM/BAM file.



!

• Don't bother. 

!

• Run a workflow that removes any unpaired reads before 

mapping. 

!

• Run the Picard Paired Read Mate Fixer after mapping 

reads. 

!

• Use sliding windows for QC, but keep empty reads.

Keeping paired ends paired: Options



NGS Data Quality: Base Quality Trimming

I’ll use Option 3 (but ...): 

• NGS QC and Manipulation → FASTQ 

Quality Trimmer by sliding window 

Check "Keep reads with zero length" 

Run again:  

• NGS QC and Manipulation → FastQC 

on trimmed dataset



NGS Data Quality: Base Quality Trimming

New Problem? 

Now some 

reads are so 

short they are 

just noise and 

can’t be 

meaningfully 

mapped 

Option 2 can fix this (but break pairings). 

Or, your mapper may have an option to ignore shorter reads



NGS Data Quality: Sequencing Artifacts

Repeat this process with MeOH Rep1 R2 (the reverse reads) 

... and there’s a problem in Overrepresented sequences: 

!

!

!

!

NGS QC and Manipulation → Remove sequencing artifacts 

But this will break pairings. 



NGS Data Quality: Done with 1st Replicate!

Now, only 5 more to go! 

Workflows? 

Create a QC workflow that does the trimming 

Or, cheat and import the Sliding window QC, paired end, 

keep empties published workflow 

Or, really cheat and just import the already trimmed datasets 

from the RNA-Seq Example → Trimmed FASTQ shared data 

library
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Cheat Alert! 

We are going to talk about Tophat but we 

aren't going to run it today: 

1. It takes a lot of time to run 

2. Tophat2 has issues on these instances 

Therefore we will talk about Tophat, and 

then use results of Tophat run that was run 

before the workshop

RNA-seq Exercise: Mapping with Tophat



Create a new history 

Import all datasets from library:  

RNA-Seq Example → Mapped Reads 

 and genes_chr12.gtf 

!

RNA-seq Exercise: Mapping with Tophat



Yes, but how might we run Tophat? 

!

• Tophat looks for best place(s) to map reads, and 

best places to insert introns  

• Imagine pages and pages of discussion on the 

intricacies and pitfalls of RNA-seq mapping here.

RNA-seq Exercise: Mapping with Tophat



!

Expected distance between paired end reads 

• Determined by sample prep 

•  We’ll use 90* for mean inner distance 

• We’ll use 50 for standard deviation 

!

!

✴ The library was constructed with the typical Illumina TruSeq protocol, 

which is supposed to have an average insert size of 200 bases. Our reads 

are 55 bases (R1) plus 55 bases (R2). So, the Inner Distance is estimated to 

be 200 - 55 - 55 = 90!

From the 2013 UC Davis Bioinformatics Short Course

Mapping with Tophat: mean inner distance

http://nescent.org/


!

You can bias Tophat towards known annotations 

• Use Own Junctions → Yes 

• Use Gene Annotation → Yes 

• Gene Model Annotation → genes_chr12.gtf 

• Use Raw Junctions → Yes (tab delimited file) 

• Only look for supplied junctions → Yes

Mapping with Tophat: Use Existing Annotations?



!

Warning: Here be dragons! 

• Allow indel search → No  

• Use Coverage Search → No  (wee dragons)

Mapping with Tophat: Make it quicker?

TopHat generates its database of possible splice junctions from two sources of evidence. The first 

and strongest source of evidence for a splice junction is when two segments from the same read (for 

reads of at least 45bp) are mapped at a certain distance on the same genomic sequence or when an 

internal segment fails to map - again suggesting that such reads are spanning multiple exons. With 

this approach, "GT-AG", "GC-AG" and "AT-AC" introns will be found ab initio. The second source is 

pairings of "coverage islands", which are distinct regions of piled up reads in the initial mapping. 

Neighboring islands are often spliced together in the transcriptome, so TopHat looks for ways to join 

these with an intron. We only suggest users use this second option (--coverage-search)  for short 

reads (< 45bp) and with a small number of reads (<= 10 million).  This latter option will only report 

alignments across "GT-AG" introns 

TopHat Manual



Some reads align to more than one place equally well. 

For such reads, how many should Tophat include? 

If more than the specified number, Tophat will pick 

those with the best mapping score. 

Tophat break ties randomly. 

Tophat assigns equal fractional credit to all n 

Mapping with Tophat: Max # of Alignments Allowed

Instructs TopHat to allow up to this many alignments to the reference for a given read, and choose 

the alignments based on their alignment scores if there are more than this number. The default is 20 

for read mapping. Unless you use --report-secondary-alignments, TopHat will report the alignments 

with the best alignment score. If there are more alignments with the same score than this number, 

TopHat will randomly report only this many alignments. In case of using --report-secondary-

alignments, TopHat will try to report alignments up to this option value, and TopHat may randomly 

output some of the alignments with the same score to meet this number. 

TopHat Manual



RNA-Seq Mapping With Tophat:  Resources

RNA-Seq Concepts, Terminology, and Work Flows  
by Monica Britton 

Aligning PE RNA-Seq Reads to a Genome 
by Monica Britton 

!

both from the UC Davis 2013 Bioinformatics Short Course 

!

RNA-Seq Analysis with Galaxy 
by Jeroen F.J. Laros, Wibowo Arindrarto, Leon Mei 

from the GCC2013 Training Day 

!

RNA-Seq Analysis with Galaxy 

by Curtis Hendrickson, David Crossman, Jeremy Goecks 

from the GCC2012 Training Day 

http://training.bioinformatics.ucdavis.edu/docs/2013/09/short-course-2013/ThuAM-rnaseq-lecture.html
http://training.bioinformatics.ucdavis.edu/docs/2013/09/short-course-2013/ThuPM-PE-tophat.html
http://training.bioinformatics.ucdavis.edu/docs/2013/09/short-course-2013/index.html
http://wiki.galaxyproject.org/Events/GCC2013/TrainingDay%23RNA-Seq_Analysis_with_Galaxy
http://www.lgtc.nl/about_us/lgtc_team.php
http://bow.web.id/
http://ngs.nbic.nl/
http://wiki.galaxyproject.org/Events/GCC2013/TrainingDay
http://wiki.galaxyproject.org/Events/GCC2012/TrainingDay%23WS9
http://wiki.galaxyproject.org/Events/GCC2012/TrainingDay


Cuffdiff?

•Part of the Tuxedo RNA-Seq Suite (as are 

Tophat  and Bowtie) 

•Widely used and widely installed on Galaxy 

instances

NGS: RNA Analysis → Cuffdiff



Cuffdiff?

Cuffdiff uses FPKM/RPKM as a central statistic. 

Total # mapped reads heavily influences FPKM/RPKM. 

Can lead to challenges when you have very highly 

expressed genes in the mix. 



Cuffdiff Alternatives

Rapaport, et al., “Comprehensive evaluation of differential gene  

      expression analysis methods for RNA-seq data.”  

      Genome Biology 2013, 14:R95 doi:10.1186/gb-2013-14-9-r95 

!

Reviews 7 packages 

!

!

Each tool has it’s own strengths and weaknesses. 

What’s a biologist to do?



Alternatives: What’s a biologist to do?

Learn the strengths and weaknesses of the tools you 

have ready access to.  Are they a good match for the 

questions you are asking? 

!

If not, then research alternatives, identify good options 

and then work with your bioinformatics/systems 

people to get access to those tools. 

!

!



Cuffdiff Alternatives: DESeq

!

DESeq is an R based differential expression analysis 

package where expression analysis is much more 

effectively isolated between features.



Cuffdiff Alternatives: DESeq

Takes a simple, tab delimited list of features and read 

counts across different samples. 

First, have to create that list. 

!

htseq-count 

Is a tool that walks BAM files producing these lists 

!



Cuffdiff Alternatives: DESeq

NGS: SAM Tools → htseq-count 

once for each BAM file 

!

Join the HTSeq datasets together on gene name 

Cut out the duplicate gene name columns 

!

OR, just use the 6x DESeq Prep workflow 

!

NGS: RNA Analysis → DE Seq



Cuffdiff Alternatives: DESeq

DESeq output is a list of genes, 

sorted by adjusted P value,  

with lowest P values listed first 
!

!

How many genes have an adjusted P value < 

0.05 ? 

!



Differential Expression:  Reading & Resources

Comprehensive evaluation of differential gene 

expression analysis methods for RNA-seq data 
by Rapaport, et al. 

!

DESeq Reference Manual	


!

DESeq Galaxy Wrapper	


by Nikhil Joshi	



!

htseq-count Galaxy Wrapper	


by Lance Parsons

http://genomebiology.com/2013/14/9/R95/abstract
http://bioconductor.org/packages/2.12/bioc/manuals/DESeq/man/DESeq.pdf
http://toolshed.g2.bx.psu.edu/view/nikhil-joshi/deseq_and_sam2counts
http://toolshed.g2.bx.psu.edu/view/lparsons/htseq_count


Galaxy Community Resources: Galaxy Biostar

Tens of thousands of users leads to a lot of questions. 

Absolutely have to encourage community support. 

Project traditionally uses mailing list 

Just moved the user support list to Galaxy Biostar, an 

online forum, that uses the Biostar platform

https://biostar.usegalaxy.org/



Galaxy Community Resources: Mailing Lists 

http://wiki.galaxyproject.org/MailingLists

Galaxy-Dev	


Questions about developing for and deploying Galaxy	



High volume (5200 posts in 2013,   900+ members)	



!

Galaxy-Announce	


Project announcements, low volume, moderated	



Low volume (    47 posts in 2013,  3400+ members)	



!

Galaxy-User (deprecated)	


Questions about using Galaxy and usegalaxy.org	



High volume (1328 posts in 2013,  2600+ members)	



http://wiki.galaxyproject.org/MailingLists


Unified Search: http://galaxyproject.org/search

Find	
  

           Everything on …	
  

                            Tools for …	
  

                               Email about …	
  

                                     Source code for …	
  

   Published Histories, Pages, Workflows, about …

                 	
  

                                 Related feature requests	
  

                  Papers using Galaxy for …	
  

Documentation on …

http://galaxyproject.org/search


Community: Public Galaxy Instances 
http://bit.ly/gxyServers

ChIP-chip and ChIP-seq? 

✓  Cistrome, Nebula 

Statistical Analysis? 

✓  Genomic Hyperbrowser 

Protein synthesis? 

✓  GWIPS-viz 

de novo assembly? 

✓  CBIIT Galaxy 

Reasoning with ontologies? 

✓  GO Galaxy 

Repeats! 

✓  RepeatExplorer

Interested in:

Over 60 public Galaxy servers

http://bit.ly/gxyServers


http://bit.ly/gxytrello

Community can create, vote and comment on issues

http://bit.ly/gxytrello
http://wiki.galaxyproject.org/MailingLists


http://wiki.galaxyproject.org

http://wiki.galaxyproject.org/MailingLists


Events News



http://bit.ly/gcc2014

http://bit.ly/gcc2014
http://bit.ly/gcc2014
http://bit.ly/gcc2014
http://bit.ly/gcc2014


We also support 
community 

organized efforts 
and events.	



!



Galaxy Resources & Community: Videos

“How to” 
screencasts on 
using and 
deploying 
Galaxy 

!

Talks from 
previous 
meetings. 

!

http://vimeo.com/galaxyproject

http://vimeo.com/galaxyproject


Galaxy Resources & Community: CiteULike Group

Over 
1500 
papers 

!

17 tags 

http://bit.ly/gxycul



Dannon Baker Dan Blankenberg Dave Bouvier

http://wiki.galaxyproject.org/GalaxyTeam

Enis Afgan John Chilton

Nate Coraor Carl Eberhard Jeremy Goecks

Greg von Kuster Ross Lazarus Anton Nekrutenko James Taylor

The Galaxy Team

Jen Jackson

Sam GuerlerDorine Francheteau Dave Clements

Nick Stoler

Marten Cech



http://wiki.galaxyproject.org/GalaxyIsHiring

Galaxy is hiring post-docs and software engineers 

Please help.

http://galaxyproject.org/wiki/GalaxyTeam
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Share: 
Make something available to someone else 

Publish: 
Make something available to everyone 

Galaxy Page: 
Analysis documentation within Galaxy; easy 

to embed any Galaxy object 
!

Let’s all share...

More Galaxy Terminology



Reproducibility:  Everybody talks about it, but ... 
!

Galaxy aims to push the goal of reproducibility from the 

bench to the bioinformatics realm 
!

All analysis in Galaxy is recorded without any extra effort 

from the user. 
!

Histories, workflows, visualizations and pages can be 

shared with others or published to the world. 

Sharing & Publishing enables Reproducibility



Sharing & Publishing enables Reproducibility



!

   http://usegalaxy.org/u/aun1/p/windshield-splatter

Sharing & Publishing enables Reproducibility

http://usegalaxy.org/u/aun1/p/windshield-splatter


Data Libraries 
Make data easy to find  

!

Genome Builds 
Care about a particular subset of life? 
!

Galaxy Tool Shed 
Wrapping tools and datatypes

Sharing for Galaxy Administrators Too


